Hello Guest User,

Please feel free to have a look around the forum but be aware that as an unregistered guest you can't see all of it and you can't post.

To access these 'Registered Users Only' areas simply register and login.

Search found 342 matches

Author: BigZCas
Sun Sep 16, 2018 5:00 pm
Forum: Projects
Topic: KZ900a4 Restoration
Replies: 25
Views: 1616

Re: KZ900a4 Restoration

Very nice Wrigers :beer
Author: BigZCas
Sat Sep 15, 2018 4:41 pm
Forum: Bike Help
Topic: Electrical Wizard Wanted
Replies: 4
Views: 169

Re: Electrical Wizard Wanted

Crimped a new connector onto the positive brown wire at the switch, all now fine.
Thank you for the help.
:D
Author: BigZCas
Sat Sep 15, 2018 4:38 pm
Forum: Bike Help
Topic: Throttle Hesitation A4
Replies: 0
Views: 69

Throttle Hesitation A4

Hello again :)
I have a split second engine hesitation between shut off throttle and opening :(
Most noticeable when pulling off..
Tick over is perfect, blasting through the gears perfect..
I'm sure someone will tell me what the problem is :oops:
Author: BigZCas
Sat Sep 15, 2018 4:32 pm
Forum: Projects
Topic: KZ900a4 Restoration
Replies: 25
Views: 1616

Re: KZ900a4 Restoration

Got the first 30 miles on her today :)
All went great except for 1 little niggle .....:lol:
See bike help :??
Author: BigZCas
Fri Sep 14, 2018 5:32 pm
Forum: Bike Help
Topic: Electrical Wizard Wanted
Replies: 4
Views: 169

Re: Electrical Wizard Wanted

Thank you Big Fluff.
The brown wire came off the connecter as I pulled it from the switch.
Tested the brown wire at 12V, so ok
The Blue wire between the 2 switches also rang out ok.
Fingers crossed when I can get hold of a new connector tomorrow and re-fit all will be well ??
Author: BigZCas
Fri Sep 14, 2018 4:48 pm
Forum: Bike Help
Topic: Electrical Wizard Wanted
Replies: 4
Views: 169

Electrical Wizard Wanted

Z900a4
Help please, I have no brake light and stop indicator lamp when using the front brake ?
Both work ok when depressing the rear brake.
I have checked the front brake switch with a meter and it is working fine.
Where do I check next ?
Cheers :??
Author: BigZCas
Thu Sep 06, 2018 11:31 am
Forum: Meetings & Events
Topic: Z-Day 2018 in Belgium
Replies: 7
Views: 293

Re: Z-Day 2018 in Belgium

Some very interesting photo's Philippe.
Thanks for sharing :D
Author: BigZCas
Mon Sep 03, 2018 11:29 am
Forum: For Sale
Topic: Z1000a2 Exhaust
Replies: 3
Views: 201

Re: Z1000a2 Exhaust

Gone :beer :beer
Author: BigZCas
Sun Sep 02, 2018 7:43 pm
Forum: For Sale
Topic: Z1000a2 Exhaust
Replies: 3
Views: 201

Re: Z1000a2 Exhaust

A drink :D
Author: BigZCas
Sun Sep 02, 2018 6:55 pm
Forum: Show us Yours
Topic: My Z1000a1
Replies: 7
Views: 516

My Z1000a1

Sorting through the loft today and finally found my photo album from back in the day (1979). :) So this meant that I now know the registration number from my first Big Z :D Having looked on the web I see that the bike was MOT'd March 2017. Anyone on here own a Z1000a1 - Reg - RWB 306R :wink: I have ...
Author: BigZCas
Sun Sep 02, 2018 6:37 pm
Forum: For Sale
Topic: Z1000a2 Exhaust
Replies: 3
Views: 201

Z1000a2 Exhaust

Any use to anyone ?
Removed from my Z1000a2.
Think that the downpipes are original ??
Collection only from LE9
Cas
Author: BigZCas
Sat Sep 01, 2018 5:50 pm
Forum: Projects
Topic: KZ900a4 Restoration
Replies: 25
Views: 1616

Re: KZ900a4 Restoration

wilsonsjw11 wrote:I'd be interested to know what work has been done to the engine internally.
Regards
Steve

All finished for now :)
No engine internal work required on this one.
Author: BigZCas
Tue Aug 28, 2018 9:49 pm
Forum: Projects
Topic: KZ900a4 Restoration
Replies: 25
Views: 1616

Re: KZ900a4 Restoration

Fingers crossed, hopfully out after the weekend :D
Author: BigZCas
Tue Aug 28, 2018 5:03 pm
Forum: Projects
Topic: KZ900a4 Restoration
Replies: 25
Views: 1616

Re: KZ900a4 Restoration

My painting is done by a friend of a friend who takes it into work. :D
Author: BigZCas
Sun Aug 26, 2018 12:00 pm
Forum: Bike Help
Topic: KZ900A4 Blowing Fuses
Replies: 24
Views: 567

Re: KZ900A4 Blowing Fuses

Hello Dave,
You are correct, I tried the same switch on another bike and the same thing happens, the 20amp fuse popped .
And so it is conclusive, the fault is with the kill switch.
Thank you all for your help and suggestions.

Go to advanced search