Hello Guest User,

Please feel free to have a look around the forum but be aware that as an unregistered guest you can't see all of it and you can't post.

To access these 'Registered Users Only' areas simply register and login.

Kz900 won’t rev over 3k

Need help restoring, building, or finding then try here.

Moderators: paul doran, Taffus, KeithZ1R, chrisu

Message
Author
User avatar
Nick.s
Regular Poster
Posts: 87
Joined: 19th Jun 2018
Location: Gloucestershire

Re: Kz900 won’t rev over 3k

#31 PostAuthor: Nick.s » Fri Jan 03, 2020 4:46 pm

I haven’t checked for air corrector jets, what do they look like? Would taking the air filter out correct it if there are correctors in?
Attachments
550464C0-5BA7-4791-BEBE-23EA9C8AC993.jpeg

needaz1100r
ZedHead
ZedHead
Posts: 1057
Joined: 11th Sep 2012
Location: Reading
Contact:

Re: Kz900 won’t rev over 3k

#32 PostAuthor: needaz1100r » Fri Jan 03, 2020 5:13 pm

zed1015 wrote:Don't go changing mains until you have sorted the 3000rpm issue.
There is no std main jet size for 1000 carbs and 4/4 pipes but 102 won't be far off for a 900 it all depends carb spec ,exhaust type and intake flow.
Stock mains on a GS1000 with VM28's is only 96 ( and the same 96 main for the Katana 1000 with 32 smoothbores )
112.5 is the average main on a stock Z1000.
There's no need to start changing settings that don't relate to the problem you have.
You wouldn't go buying specs because you are going deaf would you..


Also check the carb mouths for air corrector jets..
If the carbs have previously been run with pods on this bike or another then they may have the corrector jets still fitted.
This will also cause the bogging you describe due to over fueling with the airbox in situ.


Hallelujah! How many times do you hear, I changed the exhaust, took the airbox off and now it runs rough, do you think it's the ignition or the tyre pressure?
Cheers,

Mark.

User avatar
zed1015
Hardcore
Hardcore
Posts: 2934
Joined: 2nd Nov 2005
Location: Somewhere between Scunny and Goole.

Re: Kz900 won’t rev over 3k

#33 PostAuthor: zed1015 » Fri Jan 03, 2020 5:16 pm

There are no corrector jets in those carbs so that's not the issue.
Have you been through everything I listed in my first post.

User avatar
Nick.s
Regular Poster
Posts: 87
Joined: 19th Jun 2018
Location: Gloucestershire

Re: Kz900 won’t rev over 3k

#34 PostAuthor: Nick.s » Fri Jan 03, 2020 5:26 pm

I haven’t checked electrical fault under load, it’s got a new kill switch. Timing and auto advance ok, fuel ok. I set float levels when I overhauled the carbs, new coils.
The plugs get very sooty, in a very short time.
The only way I can rev past 3k is by feathering the throttle instead of just opening it fully, even then it only goes to about 4k
Would electronic ignition make any difference?

User avatar
zed1015
Hardcore
Hardcore
Posts: 2934
Joined: 2nd Nov 2005
Location: Somewhere between Scunny and Goole.

Re: Kz900 won’t rev over 3k

#35 PostAuthor: zed1015 » Fri Jan 03, 2020 5:33 pm

That does sound like over richness or a restriction in the intake or exhaust.
You need to try running with the airbox off or filter out.
Also try with the baffles removed or a different exhaust.
I have had pattern 4/4 exhausts that kill the performance like this.
As for the ignition. I always junk the point and fit a Dyna 'S'.
They are night and day when it comes to starting and performance.

User avatar
Nick.s
Regular Poster
Posts: 87
Joined: 19th Jun 2018
Location: Gloucestershire

Re: Kz900 won’t rev over 3k

#36 PostAuthor: Nick.s » Fri Jan 03, 2020 5:40 pm

Thanks for all your help, I really appreciate it. I hope I’m not being too much of a nuisance.
I’ll try a few thing tomorrow, it does seem like it’s air related.
Thanks again
Nick

Coose
Custard Cream
Custard Cream
Posts: 660
Joined: 20th Apr 2015
Location: North Yorks

Re: Kz900 won’t rev over 3k

#37 PostAuthor: Coose » Fri Jan 03, 2020 8:51 pm

Nick.s wrote:Well I’ve just set the valve timing properly, and checked the ignition timing. It’s still the same, all ok to 3 k revs then it splutters and won’t go any higher unless I back off the throttle then I can ease it up a bit :sad


You did move the right cam, turn over the engine and then recheck the cam timing?

User avatar
z1bman
Hardcore
Hardcore
Posts: 4350
Joined: 3rd Mar 2010
Location: WORDSLEY WEST MIDLANDS

Re: Kz900 won’t rev over 3k

#38 PostAuthor: z1bman » Fri Jan 03, 2020 9:55 pm

what are the mixture screws set at standard base setting is 1 3/4 + or - 1/8

User avatar
Nick.s
Regular Poster
Posts: 87
Joined: 19th Jun 2018
Location: Gloucestershire

Re: Kz900 won’t rev over 3k

#39 PostAuthor: Nick.s » Fri Jan 03, 2020 11:34 pm

The pilot fuel screws are set about 1.25 turns out, I started at 1.5 but it was reving too high so I turned them in 1/4 turn.

kev edwards
Hardcore
Hardcore
Posts: 1732
Joined: 3rd Apr 2009
Location: leverington UK

Re: Kz900 won’t rev over 3k

#40 PostAuthor: kev edwards » Sat Jan 04, 2020 7:49 am

For those carbs with that jetting 1and 1/8, but it is subject to a little variation, if the screws have been way over tightened before the holes will be larger and let more fuel through, do you have another set of carbs to try.

User avatar
Nick.s
Regular Poster
Posts: 87
Joined: 19th Jun 2018
Location: Gloucestershire

Re: Kz900 won’t rev over 3k

#41 PostAuthor: Nick.s » Sat Jan 04, 2020 9:22 am

I have been offered a set to try, which I will when I’ve run out of other options. It’s odd that it will rev right up in neutral, but on the road it won’t. Seems like something is breaking down under load.

User avatar
zed1015
Hardcore
Hardcore
Posts: 2934
Joined: 2nd Nov 2005
Location: Somewhere between Scunny and Goole.

Re: Kz900 won’t rev over 3k

#42 PostAuthor: zed1015 » Sat Jan 04, 2020 10:03 am

Nick.s wrote:I have been offered a set to try, which I will when I’ve run out of other options. It’s odd that it will rev right up in neutral, but on the road it won’t. Seems like something is breaking down under load.

If it's still on points have you checked the condensers.

User avatar
Nick.s
Regular Poster
Posts: 87
Joined: 19th Jun 2018
Location: Gloucestershire

Re: Kz900 won’t rev over 3k

#43 PostAuthor: Nick.s » Sat Jan 04, 2020 10:12 am

No I haven’t checked condensers. How do I check them?
I’ve just tried it with no air filter and no baffles, it reverse up to nearly 4k, when I refitted them it went back to 3k. Number 4 plug looked brownish, the rest black.

User avatar
z1bman
Hardcore
Hardcore
Posts: 4350
Joined: 3rd Mar 2010
Location: WORDSLEY WEST MIDLANDS

Re: Kz900 won’t rev over 3k

#44 PostAuthor: z1bman » Sat Jan 04, 2020 1:35 pm

a good spark will easily jump a gap of between 7 -10 mm is the spark blue ? if its yellowish it is a sign of a bad condenser

chrisw1
100Club
100Club
Posts: 358
Joined: 13th Mar 2017
Location: Oswaldtwistle

Re: Kz900 won’t rev over 3k

#45 PostAuthor: chrisw1 » Sat Jan 04, 2020 2:12 pm

I had the same issue when I finished my zed ....... back to the cam timing , you can have 28 links but both cams are 1 tooth forward if you know what i mean ........ I sorted that and it was fine


Return to “Bike Help”

Who is online

Users browsing this forum: No registered users and 14 guests